Mussfelder in Web-Formularen

Welcome to the POB User Group Online Community! Forums PUG DACH Mussfelder in Web-Formularen

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2784

    Hallo,

    bin zurück und werde Zug um Zug eure Antworten aufgreifen.
    Damit euch nicht langweilig wird eine Sache, die ich mit Birte Ottzen(Wendia-Support) schon rauf und runter deklariert habe.

    Feststellungen:
    1) In Webforms muss man mit Fragebögen und Fragen antworten
    2) Gibt man diese im Webform an, können sie dort auch als Mussfelder deklariert werden

    Problem:
    Arbeitet man z.B. mit Folgefragen, hat der Haken ‘Obligatorisch’ darin keine Auswirkung im Web.

    Anleitung zur Nachstellung:

    1) Fill in a question in web form:
    2) In that question a second one(a follow question):
    3) Those answers of the follow question I would like to be mandatory!
    BUT it doesn’t work as described in the Help!

    Da ich bis in vier Ebenen hinunter muss, kann ich auch nicht nur mit Fragebogen und Fragen arbeiten(Mussfeld funktioniert dann) und leider gibt es keine “Folgefragebögen” mit denen ich mich durchhangeln könnte.

    Wir habt ihr das gelöst?

    #2785
    Stefan Reichelt
    Participant

    Hm, so richtig sehe ich noch nicht, wo das Problem ist. Wenn du in der Folgefrage den Haken “Obligatorisch” setzt, muss es eigentlich funktionieren. Hat Dorthe das nicht als Bug anerkannt? Ich kann es gern mal testen, wär aber sehr überrascht, wenn es nicht funktioniert. Wir arbeiten in vielen Formularen mit solchen Konstellationen (auch mit “Folgefragebögen”).
    Setzt du den Haken auch wirklich auf Frageebene, wenn du mit Folgefragen arbeitest? In der WebForm-Zeile wirkt es sich natürlich nur auf die oberste Ebene aus…

    #2786

    Hallo Stefan,

    etwas konkreter:

    1) Webform “Benutzerantrag”
    2) Darin Frage IT BA 028 “Welcher Mailverteiler ist betroffen?” (weder muss in Web noch in Frage)
    [Antwort Textfeld zur Eingabe]
    3) Darin die “Neue Frage” IT BA 028.6 “Aktion zum Mailverteiler”
    [Optionsfeld(Einzelauswahl): “Benutzer hinzufügen” v “Benutzer entfernen”]

    Den Haken ‘Obligatorisch’ habe ich in der letzten Frage gesetzt, damit man unbedingt mitgeben muss welche Aktion zu dem MV vollzogen werden soll.

    Ich kann das Webform jedoch abschicken ohne eine Auswahl getroffen zu haben.
    Erhältst du ein anderes Ergebnis?

    Dorthe hat mich auf verschiedene Hilfen verwiesen und abschließend geschrieben, dass die Mussfeld-Deklaration im Webform geschehen muss – natürlich in unserem Fall nicht umsetzbar …

    #2788
    Stefan Reichelt
    Participant

    Ok, danke für die Konkretisierung. Wenn es in dieser Konstellation nicht klappt, handelt es sich höchstwahrscheinlich wirklich um einen Bug. Ich hab nur gerade nicht so viel Zeit, vielleicht kann sonst noch jemand gegenprüfen… auf jeden Fall würde ich dann bei Dorthe am Ball bleiben. Ich glaub, sie hat nicht verstanden, was mit “Follow question” gemeint war. Hast du ihr ein paar Screenshots geliefert?

    Ich hab für diesen Zweck immer meine Sandbox-Demoumgebung. Wenn es sich schwer erklären lässt, mache ich einfach ein Backup von der DB, lade es auf den Wendia-FTP hoch und lasse den Support selbst schauen.

    #2793

    Klar hat sie Screenshots erhalten …
    Wie arbeitet ihr den mit “Folge-Fragebögen”?
    In einem Fragebogen kann ich doch nur Fragen listen und keinen neue Bögen?

    #2794
    Stefan Reichelt
    Participant

    Falls du so etwas hast, solltest du vielleicht wirklich eine DB-Kopie bereitstellen, in der Wendia das Problem live nachvollziehen kann.

    Folge-Fragebögen sind eigentlich kein Problem. In der Antwortzeile kann ich Fragen, Fragebögen und sogar Webforms zuordnen. Vielleicht fehlen bei dir einfach nur die entsprechenden Spalten? Versuch mal, sie hinzuzufügen.

    #2956

    Warte auf neue Patches – vorerst erledigt.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.